‫ تغییر ورژن php

داود

سلام

از وقتی ورژن php سایتم را به 7.1 تغییر دادم این پیام به ایمیلم ارسال میشه:

PHP Warning: PHP Startup: Unable to load dynamic library '/opt/alt/php71/usr/lib64/php/modules/memcache.so' - /opt/alt/php71/usr/lib64/php/modules/memcache.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/opt/alt/php71/usr/lib64/php/modules/mysql.so' - /opt/alt/php71/usr/lib64/php/modules/mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: Module 'mysqlnd' already loaded in Unknown on line 0
PHP Warning: Module 'bcmath' already loaded in Unknown on line 0
PHP Warning: Module 'imap' already loaded in Unknown on line 0
PHP Warning: Module 'dom' already loaded in Unknown on line 0
PHP Warning: Module 'intl' already loaded in Unknown on line 0
PHP Warning: Module 'json' already loaded in Unknown on line 0
PHP Warning: Module 'PDO' already loaded in Unknown on line 0
PHP Warning: Module 'xmlreader' already loaded in Unknown on line 0
PHP Warning: Module 'fileinfo' already loaded in Unknown on line 0
PHP Warning: Module 'soap' already loaded in Unknown on line 0
PHP Warning: Module 'xmlrpc' already loaded in Unknown on line 0
PHP Warning: Module 'gd' already loaded in Unknown on line 0
PHP Warning: Module 'sockets' already loaded in Unknown on line 0
PHP Warning: Module 'xmlwriter' already loaded in Unknown on line 0
PHP Warning: Module 'mbstring' already loaded in Unknown on line 0
PHP Warning: Module 'pdo_mysql' already loaded in Unknown on line 0
PHP Warning: Module 'xsl' already loaded in Unknown on line 0
PHP Warning: Module 'mcrypt' already loaded in Unknown on line 0
PHP Warning: Module 'zip' already loaded in Unknown on line 0
PHP Warning: Module 'mysqli' already loaded in Unknown on line 0
PHP Warning: Module 'Phar' already loaded in Unknown on line 0

این مسئله را با پشتیبانی هاستم مطرح کردم این جواب را دادند:

در ورژن php 7.0 ماژول mysql و برخی دیگر ماژول های قدیمی، پشتیبانی نمی گردند و به همین جهت خطا برای شما ارسال می گردد. به جای mysql می توانید از mysqli استفاده نمایید.

راهی هست که دیگه این ایمیل ارسال نشه؟

سازنده: داود زمان ایجاد: 29 دی 1396 زمان اتمام: 30 دی 1396

پاسخ‌ها:

مرتب‌سازی بر اساس
یاسر علیمردانی تیم توسعه

سلام. شما از cpanel برای میزبانی استفاده می‌کنید یا دسترسی کامل به سیستم عامل دارید؟

یاسر علیمردانی تیم توسعه

اگر امکانش هست که به فایل php.ini دسترسی داشته باشید، این پیوند را مطالعه کنید تا مشکل شما رفع گردد.

#‫رفع #‫خطا #php7

داود
داود 30 دی 1396
نقل قول از یاسر علیمردانی

سلام. شما از cpanel برای میزبانی استفاده می‌کنید یا دسترسی کامل به سیستم عامل دارید؟

 

از دايركت ادمين استفاده ميكنم

دسترسي كامل به سيستم عامل ندارم 

یاسر علیمردانی تیم توسعه

خب فکر کنم باز هم به فایل php.ini دسترسی داشته باشید. اگر ندارید، این امکان را از پشتیبانی فنی میزبان خود فعال کنید.

داود
داود 30 دی 1396

به php.ini دسترسي دارم، تست ميكنم و نتيجه را اعلام ميكنم

این موضوع بسته شده است