‫ درباره نسخه موبایل

نسخه موبایل که حجم حدود 1.5 مگ داره رو نصب کردم ولی ظاهرا برای دسترسی به پورتال شاب هست نه شبکه ای که ما درست کردیم. درسته؟ چه طوری کاربران میتونن از طریق موبایل به شبکه ای که عضو هستن لاگین کنن؟

سازنده: محمود زمان ایجاد: 2 خرداد 1397 زمان اتمام: 5 خرداد 1397

پاسخ‌ها:

مرتب‌سازی بر اساس
محمود 3 خرداد 1397

خب طبق راهنمایی که اینجا آمده، باید از سورس کامپایل کنم. اما سئوالات مختلفی وجود داره

1- در قسمت cloud messaging، یک server key میبینم که طولانی هست و یک Legacy server key که طول رشته کمتر هست. کدوم یکی رو باید برای FCM انتخاب کنم؟

 

2- در صفحه cloud messaging، دکمه generate key pair را بزنم؟

3- شکل 10 در راهنما گویا نیست. پسوردها چی هستن؟ ایمیل باید همون ایمیل smtp باشه؟ یا ایمیلی که توسط اون firebase درست شده؟

عیسی مرادنژاد تیم توسعه
عیسی مرادنژاد 5 خرداد 1397

وقت بخیر

همونطور که خودتون هم گفتید باید فایل اپ را برای شبکه اجتماعی خودتون تولید کنید.

جواب باقی سوالات:

۱- Server Key را کپی کنید (طولانی تر).

۲- خیر لازم نیست.

۳- این قسمت هیچ ربطی به ایمیل یا تنظیمات firebase نداره. یک پسورد جدید انتخاب کنید. برای alias هم نیازی نیست که ایمیل باشد و می‌تواند هر یوزرنیمی انتخاب کنید. حتما دقت کنید که این سه مقدار (پسورد، Alias و پسورد alias) را نگهداری کنید چرا که برای تولید نسخه‌های بعدی نیاز دارید.

محمود 5 خرداد 1397

خب من v25 رو build کردم و apk ساخته شد. روی گوشی خودم که اندروید 7 هست نصب میشه و کار میکنه. ولی روی اندروید 5 و 4.1.2 نصب نمیشه.

در android-studio، برای sdk ورژن های 27، 20 و 16 نصب هستند. با توجه به این که مینیمم ورژن 16 هست انتظار دارم روی 4.1.2 نصب بشه

 

    compileSdkVersion 25
    buildToolsVersion "25.0.3"
    defaultConfig {
        applicationId "ir.iiscenter.shub"
        minSdkVersion 16
        targetSdkVersion 25
        versionCode 25
        versionName "2.6.7"
        vectorDrawables.useSupportLibrary = true
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }

ویرایش شده توسط محمود (5 خرداد 1397)
عیسی مرادنژاد تیم توسعه
عیسی مرادنژاد 5 خرداد 1397

در مرحله آخر برای تولید فایل نهایی، از نوع v2 استفاده کردید یا v1؟

لطفا این مورد رو بررسی کنید.

همچنین چه اروری به شما نشون میده؟

محمود 5 خرداد 1397

V2

با این حساب باید V1 رو انتخاب کنم

موقع نصب package manager فقط پیغام "App not install"  رو نشون میده

عیسی مرادنژاد تیم توسعه
عیسی مرادنژاد 5 خرداد 1397

بله. می‌تونید هر دو نوع رو انتخاب کنید تا هر دو پوشش داده بشه.

محمود 5 خرداد 1397

حل شد. ممنون

این موضوع بسته شده است