‫ ایجاد یا ویرایش منو

سلام

 در قسمت مدیریت صفحات وقتي منویی را برای ایجاد، ویرایش و یا حذف انتخاب ميكنم و ذخيره را ميزنم اين پيغام رو ميده : "خطایی در سامانه رخ داده است. (خطای 500) "

ویرایش شده توسط ahmadi (7 بهمن 1397)
سازنده: ahmadi زمان ایجاد: 7 بهمن 1397 زمان اتمام: 9 بهمن 1397

پاسخ‌ها:

مرتب‌سازی بر اساس
محمد آقاعباسلو تیم توسعه
محمد آقاعباسلو 7 بهمن 1397

با سلام خدمت شما،

لطفا در صورت امکان خطوط زیر را در انتهای فایل config.php واقع در پوشه ow_includes قرارداده و فایل را ذخیره کنید. کارگذار خود را بازنشانی کرده و مجددا مراحل ایجاد و ویرایش صفحه را طی کنید و پیغام خطای نمایش داده شده را برای ما در همینجا ارسال بفرمایید.

ini_set('display_errors',1);

ini_set('display_startup_errors',1);

error_reporting(E_ALL);

ویرایش شده توسط محمد آقاعباسلو (7 بهمن 1397)
ahmadi 7 بهمن 1397

خیلی متشکرم از پاسخ سریع شما

پیغام خطا به صورت ذیل می باشد :

Error details:
Type:     Critical
Message:     Invalid route params provided!
File:     /var/www/html/ow_core/route.php
Line:     166
Trace:     #0 /var/www/html/ow_core/application.php(175): OW_Route->__construct('page_qex1xexe', '', 'BASE_CTRL_Stati...', 'index', Array) #1 /var/www/html/index.php(52): OW_Application->init() #2 {main}

محمد آقاعباسلو تیم توسعه
محمد آقاعباسلو 7 بهمن 1397

تشکر فراوان

خطایی که ارسال فرمودید، متن کامل خطا هست؟ اگر نیست لطفا متن کامل خطا را اینجا قرار دهید

ویرایش شده توسط محمد آقاعباسلو (7 بهمن 1397)
ahmadi 7 بهمن 1397

متاسفانه وارد سایت و پنل کاربری نمیشود وقتی اسم سایت را میزنم این پیغام را نشان میدهد :

عیسی مرادنژاد تیم توسعه
عیسی مرادنژاد 7 بهمن 1397

با سلام

لطفا تغییرات زیر را اعمال کرده و نتیجه را گزارش دهید:

- در فایل ow_includes/config.php مقدار OW_DEBUG_MODE را برابر true قرار دهید:

define('OW_DEBUG_MODE', true);

دوباره تلاش کنید. باید ارور کاملتری مشاهده کنید.

- آدرس زیر را وارد کرده و با کاربر مدیر لاگین کنید.

http://{domain}/admin

اگر قادر به ورود به بخش مدیریت شدید، وارد بخش مدیریت صفحات شوید و صفحات جدیدی که ایجاد شده است را حذف نمایید.

- اگر قادر به لاگین نبودید، وارد جدول ow_base_menu_item شده و سطر مربوط به page_qex... را حذف نمایید (مثلا از طریق phpmyadmin).

ویرایش شده توسط عیسی مرادنژاد (7 بهمن 1397)
عیسی مرادنژاد تیم توسعه
عیسی مرادنژاد 7 بهمن 1397

همچنین اگر ممکن است لطفا توضیح دهید که چه تغییراتی در بخش مدیریت سامانه‌>مدیریت صفحات انجام داده‌اید. به طور مثال اگر منویی به منوی بالایی یا پایینی سامانه اضافه کرده‌اید.

ویرایش شده توسط عیسی مرادنژاد (7 بهمن 1397)
ahmadi 7 بهمن 1397

admin -1 که میزنم ریدایرکت می شود به خطا 500 که براتون ارسال کردم.

2- جدولی که گفته بودید را پیدا کردم ولی متوجه منظورتون از سطر مربوط به  page_qex... که گفتید نشدم

از پاسخگویتان متشکرم .

عیسی مرادنژاد تیم توسعه
عیسی مرادنژاد 7 بهمن 1397

در این جدول مقدار page_qex رو جستجو بفرمایید. اگر سطری بود که این مقدار رو داشت اون سطر رو حذف کنید.

ویرایش شده توسط عیسی مرادنژاد (7 بهمن 1397)
ahmadi 8 بهمن 1397

سلام

من تمام جدول های دیتابیس را جستجو کردم ولی چیزی که شما گفتید را پیدا نکردم

امکانش هست پاک شده باشه که سایت بالا نمیاد؟

عیسی مرادنژاد تیم توسعه
عیسی مرادنژاد 8 بهمن 1397

سلام.

اگر پاک شده بود، این مقدار نباید باعث مشکل می‌شد.

برای بررسی بهتر می‌تونید کل فایل SQL رو اکسپورت کنید و داخل اون جستجو کنید.

ahmadi 8 بهمن 1397

فایل SQL را اکسپورت و جستجو کردم و چند نام از مقدار  page_qex پیدا کردم.

عیسی مرادنژاد تیم توسعه
عیسی مرادنژاد 8 بهمن 1397

همونطور که معلومه، جستجوی قبلی که در phpMyAdmin انجام شده، به درستی جواب رو برنگردونده.

احساس میکنم فقط دو مورد آخر رو حذف کنید اصلاح بشه. این دو سطر احتمالا مربوط به همون جدول base_menu_item هستند. اگر ممکن هست اسم جدول هر کدوم از این نتایج رو هم بنویسید تا تحلیل بهتری انجام بدم.

ahmadi 8 بهمن 1397

تشکر از پاسخگویتان

حدستون درست بود دقیقاً در همین جدول بود

فقط من باید این جدول را کلا حذف کنم بعد تو دیتابیس import کنم منظورتون این بود؟

عیسی مرادنژاد تیم توسعه
عیسی مرادنژاد 8 بهمن 1397

خواهش میکنم

پیشنهادم اینه که از طریق phpMyAdmin این سطر رو پیدا کنید و پاک کنید تا راحت‌تر باشه و نیازی به حذف و واردسازی دوباره نباشه.

ahmadi 8 بهمن 1397

من این خط و نتونستم پیدا کنم.

اومدم این خطی که در شکل زیر می باشد را حذف کردم از دیتا بیس import کردم ولی سایت بالا نیامد

عیسی مرادنژاد تیم توسعه
عیسی مرادنژاد 8 بهمن 1397

لطفا از تنظیمات پرتال phpMyAdmin برای رفتن به صفحات بعدی جستجو که در شکل هم به نمایش در‌امده استفاده کنید.

تمامی خط‌های مربوطه رو پاک کنید. از جداول دیگر هم و اگر ارور جدیدی دیده شد، لطفا دوباره برای ما عکس بگیرید.

پیوست‌ها:
 
ahmadi 9 بهمن 1397

سلام خیلی ممنون از پیگیری شما

-متاسفانه مشکل من برطرف نشد و مجدد نصب کردم.

-یک سوال داشتم یک مدیر چگونه میتواند پسور کاربران دیگر را تغییر دهد.

عیسی مرادنژاد تیم توسعه
عیسی مرادنژاد 9 بهمن 1397

سلام و وقت بخیر

- مشکلی که گزارش کردید ما تاکنون در هیچ کدام از شبکه‌های اجتماعی مشاهده نکرده بودیم.

- در بخش تنظیمات افزونه «موارد امنیتی ضروری» امکان تغییر رمز کاربر وجود دارد.

با تشکر

ahmadi 9 بهمن 1397

-مشکل من احتمالا به دلیل تداخل یکی از افزونه ها هست که امکان ویرایش و ایجاد منو را به من نمیداد.

-خیلی ممنون از راهنمایتان بابت تغییر رمز.

 

عیسی مرادنژاد تیم توسعه
عیسی مرادنژاد 9 بهمن 1397

خواهش میکنم.

این موضوع بسته شده است